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1 Introduction 
LTS02 is a lap timing system designed to be used in rental kart tracks. The system 
can identify up to 60 different karts and measure their lap time with one millisecond 
accuracy. 

2 Installation requirements 
The software was tested with following hardware and software configuration: 

- CPU: Genuine Intel(R) CPU T2050 @ 1.60GHz 
- Memory: 0.99 GB RAM 
- Graphics Adapter: Mobile Intel(R) 945GM Express Chipset Family 
- Monitor resolution: 1280x800 
- Operating Systems: Windows XP SP3, Vista SP1, Win7 

3 Quick Start Guide 
 
This guide will help you to install and start the LTS02Sw software. The starting point 
is that you have a working computer with Windows XP, Vista, or Win7 operating 
system installed, and your LTS02 hardware is installed in your track according to 
LTS02 installation guide and technical specification. 

3.1 Install .NET Framework 
Install the .NET Framework 4.0 Client Profile. You can download it from 
http://go.microsoft.com/fwlink/?LinkId=131000. This step is not necessary if you have 
.NET Framework 4.0 or .NET Framework 4.0 Client Profile installed. 

3.2 Check serial (COM) port 
Check if your system has an available serial (COM) port, where the communication 
module (LTS02Com) can be plugged. If not, please install the USB-to-Serial 
converter (the converter is delivered with the LTS02 Base system). 

3.2.1 USB-to-Serial converter install 

This step is not necessary if you have an available serial (COM) port in your 
computer. 
 

1. Install the USB-to-Serial converter driver. You can use the install CD, or you 
can download the driver from www.kart-timer.com.  

2. Plug the USB-to-Serial converter into one USB port. After selecting one USB 
port, do not plug the converter into another port, because the port settings will 
be changed. 

3. Check the COM port number of the USB-to-Serial converter: Start -> Control 
Panel -> System -> Hardware -> Device manager -> Ports (COM & LPT) -> 
Prolific USB-to-Serial Comm Port (COM?) 

4. Disable all power saving and hibernating features of the computer.  
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3.3 Install LTS02Sw Lap Timer software 
Install the LTS02Sw Lap Timing software. You can use the install CD, or you can 
download the latest version of the software from www.kart-timer.com. 

3.4 Connect LTS02 hardware to your computer 
Be sure that the LTS02 hardware is installed according to LTS02 installation guide 
and technical specification. Be sure that LTS02 hardware is under power. Connect 
LTS02Com to the serial (COM) port of your computer. 

3.5 Start LTS02Sw Lap Timer software 
After installed, you can start software from your Desktop or from Start menu by 
clicking to MWS-KLT Lap Timer icon: 
 

 
 
Allow Lap Timer to access the internet if you would like to use Online Race Manager. 

3.6 Connect to LTS02 hardware 
1. Select Settings -> Port… from MWS-KLT Control Panel 
2. Select the LTS02 COM port from the list. You can check LTS02 COM port 

number according to Chapter 3.2.1, Point 3. 
3. Click Connect. 
4. Wait, until the LTS02 hardware is connected: 

 

 
 

3.7 Start using software 
1. Start new round from Race -> Start Race (F5) menu, or by pressing F5. By 

starting new round, the red flag in Results window changes to green. 
2. Start to use one of your karts installed with LTS02Tran transmitter. After 

passing magnetic strip, the result has to be displayed on Results window: 
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Now you are ready to use the LTS02 Lap Timing system, and to fully customize the 
software, and use the special features. 

3.8 Troubleshooting 
If any error occurred, please restart your computer, and make a power reset to 
LTS02 hardware.  
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4 Using the software 

 
 
The software has two main types of windows: 

- Control Panel 
- Results Window 

4.1 Control Panel 
The software settings and functions can be reached from the menu bar of the Control 
Panel. The software can be closed by closing the Control Panel. 

4.2 Results Window 
The race results can be viewed in results window. The order is determined by the 
event mode. It can be Qualify or Race. In case of Qualify mode, the first has the best 
lap time, and if more drivers have the same time, the one who was running it earlier, 
is better. In case of Race mode, the first has the most laps completed, and if more 
drivers have the same laps completed, the one who has lower total time is better.  
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You can set up the content and appearance of the Results Window. You can create 
unlimited instances of Results Windows, with different content and appearance.  

4.3 Running races 
The order of a regular race is the following: 

1. The race is started from Race -> Start race, or by pressing F5, or by clicking 
on the red lights. The lights become green.  

2. The timing is started by the first driver pass above the magnetic strip. (This 
setting can be changed.)  

3. The race can be stopped any time from Race -> Stop race, or by pressing F6, 
or by clicking on the green lights. 

4. The software alerts when the set up time or lap is over, and offers to stop the 
race. Until the confirmation the race is not stopped. (This setting can be 
changed.) 

5. After the end of the race the results can be printed. On the preview screen you 
can decide whether you want to print the page or not. (This setting can be 
changed.) 

6. The race is saved automatically for a possible reprint 
 

5 Results Window 

 
 
The race results can be viewed in Results Window. This window has two fields: 

- status field with elapsed and remaining time or lap, flag and mode 
- data field with header and data 
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5.1 Results Window settings 
The Results Window settings can be reached by Right click on Results Window -> 
Settings… 

 
 
The Result Settings… window shows: 

 
 
You can Open or Save your settings to .rfs (results form settings) file from File menu. 

 
 
You can Apply or Cancel your settings. If you apply, the Results Window appearance 
will be changed according to settings. Note that the Apply does not save your 
settings to file. 
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In next chapters, the effects of the different settings will be explained. 

5.1.1 Form settings 

- Header text: Header text of the Results Window 
- Start position: Start position x and y coordinate in pixels. 0, 0 is the top left 

corner of the screen. 
- Size: Results Window width and height in pixels. 
- Opacity: Results Window opacity. 
- Screen: number of screen if displayed with multiple monitors. 
- Full screen: Results Window is displayed in full screen (start position and size 

will be ignored). 
- Color: Click to select the background color of the Results Window. 

5.1.2 Status settings 

- Show status: Select if the status field has to be showed or not. 
- Status size(%): Size of status field height in Results Window height 

percentage. 
- Elapsed string: This text will be displayed in status, Elapsed field. 
- Remaining string: This text will be displayed in status, Remaining field. 
- Race string: This text will be displayed in status, Mode field if the mode is 

Race. 
- Qualify string: This text will be displayed in status, Mode field if the mode is 

Qualify. 

5.1.3 Status Visual style 

- Header: Select status field header font and color. 
- Data: Select status field data font and color. 
- Font size min: Minimal font size in pixels.  
- Font size max: Maximal font size in pixels. The displayed text is resized 

according to the available space, but its size will be between minimal and 
maximal font size. 

5.1.4 Data object organization 

- Show Round in Datafield: If this box is checked, the data field will display the 
current round identification number (set by Race Manager software). This 
setting is useful when you are using Race Manager to organize rounds: the 
waiting drivers can see the current round number, and can estimate, when 
their round will start.  

- Show Flag in Datafield: If this box is checked, the data field is a big flag, no 
other results are displayed. This setting is useful if you would like to use 
electronic flag (e.g. with a big LED TV which is connected to your computer). 

- Show headers: Decide if the headers in data field are showed or not. 
- Orientation: Decide if the headers and the data are displayed in row or in 

column. 
- Number: Select the number of karts to be displayed. If 0 is selected, all 

running karts will be displayed. 
- Start from: Starting position, from which the karts are displayed. These latter 

two settings are useful if you would like to display the results in multiple 
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screens, in different Result Windows (e.g. position 1-4 in first LED TV, position 
5-8 in second LED TV). 

- Order by: You can select the round order rule. Actualmode means the order is 
determined by the current Mode (Race or Qualify). Racemode and qualmode 
means the order is determined by Race order or by Qual order (regardless of 
the current Mode). Eventmode means that in the first position is who passed 
the magnetic strip last. Qualmode can be useful if you would like to show the 
fastest laps in a race. Eventmode can be useful if you would like to show the 
lap time result to a driver during the round (e.g. with a LED TV positioned after 
the magnetic strip). 

- Direction: Forward means that first position displayed first. Reverse means 
first position displayed last. 

5.1.5 Data object definition 

You can set here what to display in the data field, and what is the header name of 
this field. Every field that is in the main listbox will be displayed: 

 
The header of the field will be the text in brackets []. You can edit the main listbox 
with using the following buttons: Clear all, Delete, Copy, Add, Modify. 

 
 
Example: if you would like to add a new field with transmitter number, select 
transmitter from listbox, write the header text in Header field (e.g. Tran), then click 
Add button. 

 
 
You have to use the x: field only if you would like to display last lap – x or lap x field. 
If you use x: 0 setting to lap x, it means that all laps will be displayed. Note, that this 
setting (lap x, x: 0) is designed only for printer display, because in a long race, some 
thousands of laps have to be displayed, and refreshed. This will result in high 
computational time and slow application. If you would like to display more laps, 
please use last lap – x field, and set up as many laps as you want to display. 
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5.1.6 Data Visual style 

- Header: Select data field header font and color. 
- Data: Select data field data font and color. 
- Personal best lap: Select personal best lap font and color. 
- Overall best lap: Select overall best lap font and color. 
- Font size min: Minimal font size in pixels.  
- Font size max: Maximal font size in pixels. The displayed text is resized 

according to the available space, but its size will be between minimal and 
maximal font size. 

- Lines: Select line color. Decide if the border, header, column and row lines are 
visible or not. 

5.2 Creating new Results Window 
You can create your custom Results Window with following steps: 

- View new results window: Control Panel -> View -> New results window… 
New results window will be displayed with settings of new.rfs file. 

- Customize this window according to your needs: Right click -> Settings… 
- Save your settings as a new .rfs file: File -> Save as… 
- Apply your changes: Click Apply button. The Results Window will be displayed 

according to your settings. 
- If you would like to change the settings, you can do any time by Right click -> 

Settings… on Results Window. You can save the settings from Right click -> 
Settings… -> File -> Save…, or by Right click -> Save on Results Window. 

5.3 Printing Results Window 
You can print Results Window any time by Right click -> Print… on Results Window 

 
 
Before printing, you can use Right click -> Printer Settings… to set up the printer. 
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6 Settings 

6.1 Program settings 
The main program settings can be reached from Control Panel -> Settings -> 
Program… 

 
 
In next chapters, the effects of the different settings will be explained. 

6.1.1 Default settings 

- Clock starts after first pass: Decide if the clock starts when the first kart passes 
the magnetic strip, or when the lights become green. 

- Automatic stop: Decide if the round is stopped automatically after reaching 
time or lap limit, or ask a question if the round should be stopped or not. 

- Actual mode: Decides the current mode after starting the application. 
- Running limit: Decide if the rounds are running on time or lap limit. 
- Time limit: Time limit in minutes. 
- Lap limit: Lap limit. 

6.1.2 Printing 

- Printing list: In printing process, the data field of the Results Windows defined 
in this list will be printed out. You can edit list by Clear, Delete and Add 
buttons. If you would like to add a new Results Window for printing, first you 
have to create and save your custom Results Window. 

- Print Automatically: Decide if the printing process is started automatically after 
race stop or not. 

- Print with preview: Decide if the print preview should be showed or not during 
printing process. If the print preview is showed, you can cancel the printing 
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process with Close button of the print preview. If the print preview is not 
showed, the software will print a copy of results for each driver of the round. 

- Insert picture: You can insert a picture in .bmp format to print out on the 
header of the paper. The picture will be resized to 200x100 pixels. MWS-KLT 
logo will be printed by default if no picture is inserted. 

6.1.3 Startup forms 

You can define in Startup forms list, which Results Windows should be showed after 
starting the application. You can edit this list by Clear, Delete and Add buttons. If you 
would like to add a new Results Window, first you have to create and save your 
custom Results Window. Note that the Function keys (F3, F5, F6, and F7) are 
working only in first Results Window in this list. 

6.2 Port settings 
See Chapter 3.6 

6.3 Kart settings 
Kart settings can be reached from Control Panel -> Settings -> Kart… 
 

 
 
You can define here the Kart Name and Driver Name for each transmitter. If no Kart 
Name or Driver Name is defined here, the default names will be used. Default names 
for transmitter 1 are: Kart: #1, Driver: “”.  
 
You can Add, Remove and Clear All definitions with following buttons: 
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You can modify an existing definiton by double click on it. The Kart definiton form will 
open when adding or modifying a definiton: 
 

 
 
You can Apply or Cancel definitions with following buttons: 

 
 

6.4 External device settings 
External device settings can be reached from Control Panel -> Settings -> External 
Device… 
 



Project LTS02 
kart-timer.com Doc. title Lap Timer Software Users Guide 

Created on 2010-01-22 Doc. revision 20120524 

Last modified on 2012-05-24 Author G. Paholics 

 

© Micro WS-KLT s.r.o. - 16 - www.kart-timer.com 

 
 
You can Apply or Cancel settings with following buttons: 

 
The Apply button will save your settings, but they are valid only after application 
restart.  

6.4.1 Device 

You can clear all, remove, add new, and save external device with following buttons: 

 
Please save your current device settings before adding or editing new device. 

6.4.2 Setup 

- Name: The name of external device. 
- Active: Decides if the device is active or not. 
- Update: If the device is active, the software will send data in every x second 

specified here. 
- Init (Hex): If the device is active, the software will send the init message once 

after software startup. Note that the message is in hexadecimal format, and in 
range of 1- 7FFFFFFF. Zero value is defined as none (no zero value will be 
sent). 

- Address: Specify the device IP address if the device is connected into the 
Local Network. The software will try to connect to device as a TCP Client. 
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Write “COM” in this field if the device is connected into the serial port of the 
computer. 

- Port: port of the external device. If the device address is connected into serial 
port COM5, the port number is 5. 

- Baudrate: You have to define it only if the device address is “COM”. 

6.4.3 Data 

If the device is active, the software will send data in every x second specified in 
Setup -> Update field. The data is built up of Begin message – Data fields – End 
message. The Data fields are separated with Data separator. If any of the fields is 
zero (including Begin and End message), the software will not send this field. Note 
that the messages can be specified in hexadecimal format, and they are in range of 
1- 7FFFFFFF. 

- Result: you can specify here a result settings form. The datafield of the results 
form will be sent, with chr(9) as tabulator, and chr(13) + chr(10) as new line. 

- Remaining Time or Lap: Remaining time or lap will be sent (depending on 
running limit) if this checkbox is checked. 

- X Seconds or Laps Before Round Stop: The specified message will be sent if 
this condition is true. 

- Round Started: The specified message will be sent if this condition is true. 
- Round Stopped: The specified message will be sent if this condition is true. 

6.4.4 MWS-KLT Display 

You can use MWS-KLT display to display remaining time or lap, and last lap times. 
The display shows the last lap times in [ kartname space laptime ] format (for 
example: 5 25.33 is displayed for kart 5, last lap 25.33). 

- Rows: Specify the number of rows in display. 
- Remaining Time or Lap: Remaining time or lap will be displayed in first row if 

this checkbox is checked. 

6.5 Online Race Manager 
Race Manager settings can be reached from Control Panel -> Race Manager -> 
Settings... 
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If you are using Online Race Manager to organize rounds, you have to check Use 
Race Manager checkbox, and specify the Track ID and password (sent to every track 
registering Online Race Manager). The connection status to the Race Manager is 
displayed in the status field of the Control Panel. 
 
Next round in the Online Race Manager queue can be started by clicking the Race 
Manager -> Next Round... button. The details of the next round are synchronized 
from the Online Race Manager.  
 

 
 
The results are uploaded back to the Online Race Manager after the end of the race. 
You can find more details about Online Race Manager in the Online Race Manage 
Users Guide. 

6.6 Offline Race Manager 
Offline Race Manager can be used where internet connection is not available. The 
membership database is stored at the local computer. Results are not stored in the 
Offline Race Manager. You can find more details about Offline Race Manager in the 
Offline Race Manage Users Guide. 

6.7 Top Times 
Lap Timer software can detect, store and upload top times. There are 3 lists in which 
the top times are collected: 

• Top 24 Hours 

• Top 7 Days 

• Top 1 Year  
 
You can reach Top Times settings from Control Panel -> Settings -> Top Times... 
menu. 
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If the Use Top Time checkbox is checked, the software will detect and store top times 
after each round. Add Top Time confirmation dialog is displayed where the driver 
name can be changed. 
 

 
 
You can display top times in default browser and clear top times with Show button, or 
from Control Panel -> View -> Top Times...  
 
You can clear the top times list with Clear button. 
 
Top times can be uploaded to our webserver. Please contact us if you wish to create 
a storage to your top times list. You can select Automatic Upload when your timing 
computer is connected to the internet continuously. You can upload top times 
manually with Upload button. 
 
You can insert these lists into your website by using iframe elements. You can 
change the default style of the lists to match your website design.  
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7 Statistics 

7.1 Kart Statistics 
Kart statistics can be reached from Control Panel -> View -> Kart Statistics… 
 

 
 
You can see here the running laps and running time for each transmitter. The laps 
and time can be cleared by Clear all (clearing all transmitters) or by Remove 
(removing only the selected transmitter) button. The clearing is completed only after 
clicking Apply button. Note: If you are swapping the transmitters between different 
karts, you have to clear statistics by each transmitter change to get reliable kart 
statistics results. 

8 Race menu 

8.1 Start race (F5) 
You can start the race from Race -> Start race (F5), or by pressing F5, or by clicking 
on the red lights. The lights become green. You can start race only when it is 
currently stopped. 

8.2 Stop race (F6) 
You can stop the race from Race -> Stop race (F6), or by pressing F6, or by clicking 
on the green lights. The application asks if the race should be stopped, if the 
Automatic stop is not checked in Program settings (see Chapter 6.1.1). The printing 
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process is started automatically if the Print automatically is checked in Program 
settings (see Chapter 6.1.2). The lights become red. You can stop race only when it 
is currently started. 

8.3 Mode (F7) 
You can switch current mode between Race and Qualify from Race -> Mode (F7) or 
by pressing F7 or by clicking the Mode field of the first Results Window. 

8.4 Edit race (F3)… 
You can edit race from Race -> Edit race (F3)… or by pressing F3. You can split or 
unite laps of the current round. 
 

 
 

8.5 Load race… 
You can load race from Race -> Load race… All races are saved with following file 
format: yyyymmdd_hhmmss.asv. If the system is crashed for any reasons, the last 
round is saved with date and time of the next software startup. 

8.6 Print race… 
You can start the printing process any time from Race -> Print race…  

8.7 Export race 
You can export race results to Clipboard. Then you can paste it (Ctrl+V) into an excel 
sheet. 
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9 Notes 
This document may contain preliminary information and is subject to change without 
notice. Check the updates at www.kart-timer.com. 


